Cannot reach Chess.com support

agamemnon12

I paid for a Diamond membership over 16 days ago. The money was taken from my Paypal account, but my Chess.com membership has not been upgraded yet. I have written 3 separate emails from 2 different accounts over the last 2 weeks with no response. I've also tried contacting Chess.com on Twitter. How can I escalate my complaint?

IMBacon

Probably because you have been dead for thousands of years...

batgirl

Try messaging @Kayt . If she can't help you directly, I'm sure she'll be more than happy to direct your problem to the proper person.

 

batgirl

Either that or you could launch 1000 ships. 

agamemnon12

Ha! Well said you both, and thanks @batgirl for the suggestion. I'll message @Kayt now.

IMBacon
agamemnon12 wrote:

Ha! Well said you both, and thanks @batgirl for the suggestion. I'll message @Kayt now.

Obviously stuff happens, but staff is usually very good about responding, and responding in a timely matter.

agamemnon12

I'm just very surprised as it has been so long now, and after so many messages there is still no reply from staff at all. I tried looking at @Kayt's profile, but she has asked that people not contact her with site-related issues. Any other suggestions would be appreciated, thanks!

IMBacon

If you havent yet.  Try this link

https://support.chess.com/customer/portal/emails/new

 

RonaldJosephCote

  Click the question mark icon at the bottom left.......? Try "billing issues" address your query to Matt.

Amizade

Several times I lost the matches because the connection with the chess.com falls but mine did not. What can I do? Cancel the chess.com? Because my connection is great. Something with the server?

 

baddogno
Amizade wrote:

Several times I lost the matches because the connection with the chess.com falls but mine did not. What can I do? Cancel the chess.com? Because my connection is great. Something with the server?

 

This might help:

https://support.chess.com/customer/en/portal/articles/1444918-my-internet-connection-is-fine---why-am-i-getting-disconnects-

agamemnon12

Thanks @IMBacon and @RonaldJosephCote for those suggestions. I've followed both of those routes before a few times, but just for completeness sake I've sent a desperate message using the Help-> Billing link once again. It seems very bizarre to continue receiving no response for nearly 3 weeks, but I appreciate the user support I'm getting here.

IMBacon
agamemnon12 wrote:

Thanks @IMBacon and @RonaldJosephCote for those suggestions. I've followed both of those routes before a few times, but just for completeness sake I've sent a desperate message using the Help-> Billing link once again. It seems very bizarre to continue receiving no response for nearly 3 weeks, but I appreciate the user support I'm getting here.

Glad to help, and i hope everything gets worked out.