Quality of website highly degraded.

superchessmachine

I used to have a diamond member ship for a year. It's term was over today. Now the website experiences extreme lag and other malfunctions. Moving pieces is very hard. They lag too much. Some webpages like news do not open and my web browser crashes. What is this chess.com?

superchessmachine

alright

 

 

superchessmachine

I was playing and suddenly I was able to move all pieces at once but nothing registered

superchessmachine

I wonder why?

 

fischerrook

It's all in your mind  happy.png

 

superchessmachine

Not really

 

 

wanmokewan

I've been a free member after paying for over a year.  I never had any issues after going free, so something on your end.  *shrug*  

superchessmachine

I mean the website itself is fine but the running quality is highly degraded

MathWizKidA

That's strange. I (almost) never experience any issues with this device.

superchessmachine

MathWizKidA wrote:

That's strange. I (almost) never experience any issues with this device.

Well you have diamond

Postafi

null

The new usual.

superchessmachine

yes same here.

And my wifi is good.

superchessmachine

Look. Now I have proof that the website is messed up without paying.

nullMy wifi was fine and my other tabs were functioning fine. I lost the game to a 753 and lost 14 points in a tournament I could have won.

superchessmachine

Why is chess.com like this? Do any of you non subscribed members have some experiences like this?

 

MickinMD

I never had a problem as a free member and the problems I've had as a paid member I attribute to my cheap Internet Service Provider.

Postafi

In desperation, tried reverting to green/neo board/pieces default chess.com setting. Hoped in vain it might mean less lag and freeze.

Was premium for a week (courtesy chess.com). Makes no difference.

null

Pretty much self-explanatory. Next sign should read: "Did you mean to play chess?"

superchessmachine

Yes. But why do I only experience problems when without premium.

SuniForce_YT

hi MathWizKidA!!!!! I've never had any problems. It's probably your computer or something like that. 

superchessmachine

Oh no it is not. I have a intel wifi adapter of good quality and a i7-7700. And my wifi is 5G fiber optic

SuniForce_YT

Then your browser is messed up.