Chess - Play & Learn


FREE - In Google Play

FREE - in Win Phone Store


iPhone app bugs

  • #1

    Here's a small list of bugs from the last few iPhone app versions:


    1. Pressing Analyze mode brings up a loading symbol, where in previous versions there was no wait.  Also, pressing reset position makes you wait.


    2. Memory leak - if you leave the app running in the background, when you return to play, everything is slow and laggy until you manually close the app and run it again.

    3. The order of your games resets every time you make a move - when I skip a few games and finally make a move, I get sent back to the very first game that I originally SKIPPED.  Then I have to proceed skipping games until I get to a new game - make a move, and get sent back to the first game again.  This was never an issue in older versions.

    I've made a thread about issue #3 in the past, but no responses.  Hope I'm explaining this clearly as it is a huge annoyance.  I've been using an old version of the Chess.com app from a year ago becuase of this.  PLEASE FIX!!!  I'll pay money!  (in the form of renewing my membership ;P) 

  • #2

    What version of the app and of iOS do you currently have?

  • #3

    I'm using Chess 2.3.0.ipa, none of the above bugs are in this version.

  • #4

    Hello, since the new chess.com app came out, none of the features listed above were fixed.

    I reverted back to Chess.2.3.0.ipa but I am now unable to login.  I am getting an error message: Invalid Password.

    Please help here as I cannot stand the lag time on the new app as well as the Game Order Issue listed in #3 above.

    Thank you.

  • #5

    Anyone else have trouble seeing all the rating information?  This has always been a problem for me.  I'm using an iPhone 4S.  Typically I'm only missing out on some of the graphs.

  • #6

    Yeah, that's the mobile version of the website you're looking at.


    No response, no fixes on the app.

    This is utterly ridiculous - the new "apps" play my games out of order making my chess time more frustrating than enjoyable.  There are noticeable lag times due to faulty programming and the mobile version of the website has been Out Of Order for over a year now.


    What is the deal here, Chess.com?  This is great way to lose subscribers.

  • #7

    Hi guys, sorry for the late response :(

    @jabronii- I'm not sure what version of the app you're using? The latest you should be on is 2.8.27 (which was updated March 15th in the App store). Also, what type of connection are you using? What version of iOS do you have on the phone?

    Thanks for the extra info!

  • #8

    I'm trying to use Chess2.3.0.ipa on iPhone 5 version 6.1.2

    I don't want to use the new version due to the bugs listed above.  I was using the old version fine until last week, I started to get an 'Invalid Password' error.

    Can you please fix this so that I can continue to use Chess2.3.0.ipa???

    Otherwise, cancel my subscription.  Thanks.

  • #9

    The version Chess 2.3.0.ipa is working again so all is good!

    Anyone annoyed with the newer iPhone versions, I uploaded Chess 2.3.0.ipa below, which doesn't have any of the above issues :)


  • #10

    The iPad App will no longer start up since the update last june /july (can't remember exact date). I get the splashscreen (black with pawn and claim "play. learn. share.") and after about 10 seconds I land on my iPad homescreen again. I just tried the new update of Sept. 25 and the problem persists. I will now reinstall an older version of the app which I have put aside as backup. I'm on an iPad 2 with iOS 5.1.1. which is an older system, but that should be no excuse.

    Please check this and adress the problem in future APP releases. I pay good money for the diamond membership and mainly access your offerings via the iPad app. Smile


  • #11

    philoupin- Sorry you're having troubles. Did you try a fresh install of the iPad app (newer version) rather than just an update?

  • #12

    Yes, just tried it again. Deleted App from iPad, then went into App store to do a fresh install. Same problem: splashscrenn for about ten seconds then I am back at my iPad home screen. I have not restarted the iPad inbetween, guess that makes no difference? It worked until the Update in June or July this year.

    Thanks for your help,


  • #13

    Try power cycling the iPad. If that doesn't work I'd like to try to get the crash reports from you. Do you sync your device with a Windows PC or a Mac?

  • #14

    With a mac. I'll try to delete the Chess.com App, shut down iPad, then install new version and see what happens. I will google the crash reports to see where to find them, I should manage to figure that out.

  • #15

    Doesn't work, do you want to send me a message with an email adresse to mail the crash log to? 

  • #16

    Sorry for the delay! Please send the crash log to [email protected] I'll keep an eye out for it and let you know when I get it. 


Online Now