Custom Puzzles Error iOS

iOS 3.9.29 (3)

I’m on your latest app version for iOS.

When clicking on Puzzles > Custom Puzzles > selecting categories > Start

I get an error message of “Oops! Looks like that request is no longer valid!” And I have to force quit the app to get back in.

Any estimate on when this bug will be addressed?

iOS 3.9.29 (3)

Just encountered this same bug, am on latest version on iOS. Doesn’t occur with all selections, but does occur when choosing for example Back Rank. On Android no peoblems.  Please respond.

Occurs for me too. I wish it would go away.
I’m facing the same issue. Not able to play custom chess. I’m very disappointed.
I had the same thing happen to me just now. I wanted to look and see if anyone else had this issue. Hopefully this gets resolved soon…
I think I solved this— it happens when you try a puzzle that you have never tried before (e.g a puzzle type with a 0% beside it) and check the box “Puzzles I Missed” which essentially tried to find puzzles of that type that you failed on, when there are none. Simply unchecking that slider fixes it.