Chess - Play & Learn


FREE - In Google Play

FREE - in Win Phone Store


Slow to load - can it be fixed?

  • #1

    Usually, when I make my moves, I move from game to game almost instantaneously, lately it seems to be so SLOW.

    Is anyone else have trouble?

  • #2

    I'm not sure if I have add blocker, but I would remove add blocker if I knew how?

    any suggestions would be helpful-  it's so slow I'm about to switch to another chess website.

  • #3

    I am using Mozilla Firefox

  • #4

    I juct check internet speed to see if the cause of the very slow game loads were my fault, and my down load speed checked at 6805 with up load at 494, so the slowness is not at my end.

    I will contact chess.com's staff, thanks for the idea.

  • #5

    The reply from Chess.com was no help... he said that "MAYBE" the sight is slow at the moment and the best he could offer was try control R, for an instant refresh..

    I sometimes have two min wait to load a single page before I can move.

    other's here have told me they are NOT experiencing any problems.

    At one time I had over 70 games going here, I'm down to around 10 games now.

    I'll give chess some time, but I'm not holding my breath.

  • #6

    still having problems??

  • #7

    erik wrote:

    still having problems??

     i have a problem that for a game in which it's my move, the board will load but the pieces do not
    support staff have told me to try ctrl+r which has not fixed my problem
    if i repeat it many times the pieces do sometimes appear
    support also told me to restore my computer from a back-up taken from a time when the pieces did load ( ps what's a back-up ) ok so it is probably a problem with my computer but if anybody has a tip that could help it would be appreciated - thank you, wayne

  • #8
    having said all that , i tried it again and this time the pieces loaded and i was able to make my move however this entire message is totally blank and i am continuing in the hope that when i post it it can still be read - i have tried ctrl+r

Online Now