Bug report: iPhone/iPad



1. I tried to view my games on my iPad. For the last one (http://www.chess.com/echess/game.html?id=52355445), I played the move 31. ... Nh4 and got back to the game list. The game was still listed, I tried to play my move again. But nothing changed (I don't have the latest version of the app, I'll install it later).

2. Before trying anything else, I updated the app on my iPhone. Then I went to the game list. The game was still listed. I tried to make my move but it didn't work. I noticed that my move in the move list was noted as "null move".

I tried again from the game list to the game and I waited long enough to be punished by the app: to my great horror, I saw some of my pawns and pieces disappear (the Knight and the pawn e5-d6-c5, maybe my Bishop). I was so shocked that I didn't really check the position but I think that my opponent had a lot of stuff less on the board too.

3. Then I connected with a computer and to my great relief, the move had been played.

I hope that you know what is the cause of this problem and that you can solve it because it doesn't really motivate to play on a more mobile device :)

Thank you in advance for your comments (of course not on the game itself because we are still playing!)



[edit: I posted here because I couldn't find the support center anymore, it at the bottom of the page: "Help & Support", I sent a copy to the support team]


Chess is an exciting game, by phone.   Tongue out