Forums

Can we PLEASE stop castling by clicking the rook?

Sort:
levis850
MATTHEWch6v14 wrote:
levis850 wrote:

Agreed, have lost multiple games due to this "feature". Should be able turn it off.

You can...

How can I? Don't see anything like that in the settings

ChessicallyDisabled

That's correct, there's nothing like that in settings. If you happen to use Lichess however, in preferences (which is settings) under "Game behaviour" scroll to "Castling method" and click "Move king two squares" instead of "Move king onto rook". This will prevent castling in case you happen to either drag your king to the rook or click the king and then the rook.

MATTHEWch6v14
levis850 wrote:
MATTHEWch6v14 wrote:
levis850 wrote:

Agreed, have lost multiple games due to this "feature". Should be able turn it off.

You can...

How can I? Don't see anything like that in the settings

Go to "All settings" at the bottom left of your screen, then "board and pieces", then "move method". Then set to "Drag ONLY".

levis850
MATTHEWch6v14 wrote:
levis850 wrote:
MATTHEWch6v14 wrote:
levis850 wrote:

Agreed, have lost multiple games due to this "feature". Should be able turn it off.

You can...

How can I? Don't see anything like that in the settings

Go to "All settings" at the bottom left of your screen, then "board and pieces", then "move method". Then set to "Drag ONLY".

Thanks, this is quite a decent work around but not a real solution. The thing is I like point and click, just I wish it didn't castle when you click king and rook. Castling should only happen I click the square where king goes when you actually want to castle.

MATTHEWch6v14

Oh I see. Hopefully you will get used to it and make less unnecessary blunders happy.png.

ChessPawn921

@ClassicallyDisabled joined and then closed just hours later. Lol